<!DOCTYPE html>
<html lang="en-US">
<head>
    <meta charset="UTF-8"/>
    <meta http-equiv="X-UA-Compatible"
          content="text/html"/>
    <link rel="preconnect" href="//fonts.googleapis.com" crossorigin>
    <link rel="dns-prefetch" href="//fonts.googleapis.com">
    <link rel="dns-prefetch" href="//cdn.advertserve.com">
    <link rel="dns-prefetch" href="//www.google-analytics.com">
    <link rel="dns-prefetch" href="//www.googletagmanager.com">
    <link rel="dns-prefetch" href="//practicalecommerce.advertserve.com">
    <link rel="preload" as="font" type="font/woff2" href="/wp-content/themes/pec/fonts/fontawesome.woff"  crossorigin="anonymous">

	
    
            <!-- Google Tag Manager -->
        <script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
                    new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
                j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
                'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
            })(window,document,'script','dataLayer','GTM-54R359');</script>
        <!-- End Google Tag Manager -->
    
			<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
	
	    <link rel="publisher" href="https://plus.google.com/+Practicalecommerce">

    <link rel="pingback" href="https://www.practicalecommerce.com/xmlrpc.php" />


	<title>SEO: Keyword Research for Product Content | Practical Ecommerce</title>

<!-- This site is optimized with the Yoast SEO Premium plugin v13.1 - https://yoast.com/wordpress/plugins/seo/ -->
<meta name="description" content="For many commerce businesses — omnichannel retailers, ecommerce-only merchants, wholesalers — attracting a steady flow of site visitors from organic search results is vital for success. But achieving high rankings in those results requires optimizing a site with relevant content."/>
<meta name="robots" content="max-snippet:-1, max-image-preview:large, max-video-preview:-1"/>
<link rel="canonical" href="https://www.practicalecommerce.com/seo-keyword-research-for-product-content" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="SEO: Keyword Research for Product Content | Practical Ecommerce" />
<meta property="og:description" content="For many commerce businesses — omnichannel retailers, ecommerce-only merchants, wholesalers — attracting a steady flow of site visitors from organic search results is vital for success. But achieving high rankings in those results requires optimizing a site with relevant content." />
<meta property="og:url" content="https://www.practicalecommerce.com/seo-keyword-research-for-product-content" />
<meta property="og:site_name" content="Practical Ecommerce" />
<meta property="article:publisher" content="https://www.facebook.com/practicalecommerce" />
<meta property="article:tag" content="Content Marketing" />
<meta property="article:section" content="SEO" />
<meta property="article:published_time" content="2021-02-14T10:00:30+00:00" />
<meta property="article:modified_time" content="2021-02-14T10:37:13+00:00" />
<meta property="og:updated_time" content="2021-02-14T10:37:13+00:00" />
<meta property="og:image" content="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Keyword-Research-for-Product-Content.jpg" />
<meta property="og:image:secure_url" content="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Keyword-Research-for-Product-Content.jpg" />
<meta property="og:image:width" content="360" />
<meta property="og:image:height" content="240" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="For many commerce businesses — omnichannel retailers, ecommerce-only merchants, wholesalers — attracting a steady flow of site visitors from organic search results is vital for success. But achieving high rankings in those results requires optimizing a site with relevant content." />
<meta name="twitter:title" content="SEO: Keyword Research for Product Content | Practical Ecommerce" />
<meta name="twitter:site" content="@practicalecomm" />
<meta name="twitter:image" content="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Keyword-Research-for-Product-Content.jpg" />
<meta name="twitter:creator" content="@ecommerceboy" />
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel="alternate" type="application/rss+xml" title="Practical Ecommerce &raquo; Feed" href="https://www.practicalecommerce.com/feed" />
<link rel='stylesheet' id='pec-google-fonts-css'  href='https://fonts.googleapis.com/css?family=Open+Sans+Condensed%3A300%2C700%7COpen+Sans%3A300%2C400%2C600%2C700&#038;display=swap&#038;ver=5.4.4' type='text/css' media='all' />
<link rel='stylesheet' id='wphb-1-css'  href='https://hb.wpmucdn.com/www.practicalecommerce.com/79e2e05a-87e9-4a01-887e-5af944ffb8a2.css' type='text/css' media='all' />
<script type='text/javascript' src='https://www.practicalecommerce.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/caf55a42-bda4-49a2-a1f4-20e86e1845cd.js' defer filler=''></script>
<script type='text/javascript'>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</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/2e7cf418-8635-4264-83b2-683a9740dbec.js' defer filler=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ccpa_data = {"opt_out_prompt":"Do you really wish to opt out?","opt_out_confirm":"Confirm","opt_out_cancel":"Cancel"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/57ff4cbc-dabe-4038-b199-a44fad919231.js' defer filler=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"1","sampling_rate":"10","ajax_url":"https:\/\/www.practicalecommerce.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts\/","ID":"367729","token":"a49507c93e","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/2d0c89ca-e2ca-4073-8ac0-45811aabd071.js' defer filler=''></script>
<link rel='https://api.w.org/' href='https://www.practicalecommerce.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.practicalecommerce.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.practicalecommerce.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.4.4" />
<link rel='shortlink' href='https://www.practicalecommerce.com/?p=367729' />
<link rel="alternate" type="application/json+oembed" href="https://www.practicalecommerce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.practicalecommerce.com%2Fseo-keyword-research-for-product-content" />
<link rel="alternate" type="text/xml+oembed" href="https://www.practicalecommerce.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.practicalecommerce.com%2Fseo-keyword-research-for-product-content&#038;format=xml" />
<script type="text/javascript">
jQuery(document).ready(function() {	

	
	jQuery('#simple-popup').click(function(e) {
		e.preventDefault();
		
                var id = jQuery(this).attr('href');
                //var maskHeight = jQuery(document).height();
                //var maskWidth = jQuery(window).width();
                //jQuery('#spmask').css({'width':maskWidth,'height':maskHeight});
                //jQuery('#spmask').fadeIn(1000);       
                //jQuery('#spmask').fadeTo("slow",0.8); 
                var winH = jQuery(window).height();
                var winW = jQuery(window).width();
                jQuery(id).css('top',  winH-20-jQuery(id).height()-40);
                jQuery(id).css('left', 60);
                //jQuery(id).css('top',  winH/2-jQuery(id).height()/2);
                //jQuery(id).css('left', winW/2-jQuery(id).width()/2);
                jQuery(id).animate({"left": "-=500px"}, 0);
                var patt=/\/newsletter-signup/g;
                var pat2=/\/upload/g;
                var pat3=/\/thank-you-for-confirming-your-email/g;
                if ( !patt.test(window.location) && !pat2.test(window.location) && !pat3.test(window.location) ) { jQuery(id).fadeIn(1); }
                jQuery(id).animate({"left": "+=500px"}, "slow");  	
	});
	jQuery('.window .close').click(function (e) {
		e.preventDefault();
		//jQuery.cookie('popup_hide','true',{path: '/'});
		jQuery.cookie('popup_hide','true',{expires: 90, path: '/', domain:'.www.practicalecommerce.com'});
		jQuery('#spmask').hide();
		jQuery('.window').hide();
	});		
	
	jQuery(document).keyup(function(e) {
  	if (e.keyCode == 27) { jQuery('.window .close').click(); }
});

jQuery("#simple-popup").bind('click',function()
{
	return false;
});
if ( jQuery.cookie('popup_hide') != 'true' )
{  
	setTimeout( function() {
	    if ( jQuery.cookie('popup_hide') != 'true' ) {
            jQuery('#simple-popup').click();
        }
	}, 15000 );
}
});



</script>


<!-- Theme version -->
<meta name="generator" content="Initiator " />
<meta name="generator" content="CoLabsFramework 1.4.4" />
	<link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="https://www.practicalecommerce.com/feed" />
	<link rel="pingback" href="https://www.practicalecommerce.com/xmlrpc.php" />
	<link rel="alternate" type="text/xml" title="RSS .92" href="https://www.practicalecommerce.com/feed/rss" />
	<link rel="alternate" type="application/atom+xml" title="Atom 0.3" href="https://www.practicalecommerce.com/feed/atom" />

<!--[if IE 6]>
<script type="text/javascript" src="https://www.practicalecommerce.com/wp-content/themes/pec/includes/js/pngfix.js"></script>
<![endif]-->
<!--[if IE 7]>
<link href="https://www.practicalecommerce.com/wp-content/themes/pec/includes/css/ie7.css" rel="stylesheet" type="text/css" />
<![endif]-->

                        <script type="text/javascript">
                        jQuery(document).ready(function($) {
                        jQuery("form").each(function(){
                        jQuery(this).removeClass("wpl-track-me");
                        });
                        });
                        </script><style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>		<style>
			.algolia-search-highlight {
				background-color: #fffbcc;
				border-radius: 2px;
				font-style: normal;
			}
		</style>
		<script type="text/javascript">var algolia = {"debug":false,"application_id":"N3YZXH7FK5","search_api_key":"8cfa20a94a420cc77e4982f4ad4b32eb","powered_by_enabled":false,"query":"","autocomplete":{"sources":[{"index_id":"searchable_posts","index_name":"wp_searchable_posts","label":"All posts","admin_name":"All posts","position":10,"max_suggestions":5,"tmpl_suggestion":"autocomplete-post-suggestion","enabled":true}],"input_selector":"input[name='s']:not('.no-autocomplete')"},"indices":{"searchable_posts":{"name":"wp_searchable_posts","id":"searchable_posts","enabled":true,"replicas":[]}}};</script>		<!-- Facebook Pixel Code -->
		<script>
			var aepc_pixel = {"pixel_id":"1722557321255313","user":{},"enable_advanced_events":"yes","fire_delay":"0"},
				aepc_pixel_args = [],
				aepc_extend_args = function( args ) {
					if ( typeof args === 'undefined' ) {
						args = {};
					}

					for(var key in aepc_pixel_args)
						args[key] = aepc_pixel_args[key];

					return args;
				};

			// Extend args
			if ( 'yes' === aepc_pixel.enable_advanced_events ) {
				aepc_pixel_args.userAgent = navigator.userAgent;
				aepc_pixel_args.language = navigator.language;

				if ( document.referrer.indexOf( document.domain ) < 0 ) {
					aepc_pixel_args.referrer = document.referrer;
				}
			}
		</script>
		<script>
						!function(f,b,e,v,n,t,s){if(f.fbq)return;n=f.fbq=function(){n.callMethod?
				n.callMethod.apply(n,arguments):n.queue.push(arguments)};if(!f._fbq)f._fbq=n;
				n.push=n;n.loaded=!0;n.version='2.0';n.agent='dvpixelcaffeinewordpress';n.queue=[];t=b.createElement(e);t.async=!0;
				t.src=v;s=b.getElementsByTagName(e)[0];s.parentNode.insertBefore(t,s)}(window,
				document,'script','https://connect.facebook.net/en_US/fbevents.js');
			
						fbq('init', aepc_pixel.pixel_id, aepc_pixel.user);

						setTimeout( function() {
				fbq('track', "PageView", aepc_pixel_args);
			}, aepc_pixel.fire_delay * 1000 );
					</script>
				<noscript><img height="1" width="1" style="display:none"
		               src="https://www.facebook.com/tr?id=1722557321255313&ev=PageView&noscript=1"
			/></noscript>
				<!-- End Facebook Pixel Code -->
				<style type="text/css" id="wp-custom-css">
			/*
You can add your own CSS here.

Click the help icon above to learn more.
*/
		</style>
		<!-- Custom Favicon -->
<link rel="shortcut icon" href="https://www.practicalecommerce.com/wp-content/uploads/2014/04/favicon_x16.png"/>

    <link rel="apple-touch-icon" href="/wp-content/uploads/2015/05/practical-ecommerce-icon.png" />
    <link rel="apple-touch-icon" sizes="57x57" href="/wp-content/uploads/2015/05/practical-ecommerce-icon-114.png" />
    <link rel="apple-touch-icon" sizes="114x114" href="/wp-content/uploads/2015/05/practical-ecommerce-icon-114.png" />
    <link rel="apple-touch-icon" sizes="72x72" href="/wp-content/uploads/2015/05/practical-ecommerce-icon.png-144" />
    <link rel="apple-touch-icon" sizes="144x144" href="/wp-content/uploads/2015/05/practical-ecommerce-icon-144.png" />
    <meta name="viewport" content="width=device-width, initial-scale=1">
    <script type="text/javascript">
    function pecDidAdLoad( element ) {
        return element.hasAttribute("data-modified");
    }

    function pecAdLoaded(args, err) {
        var checkCount = 0;
        var adElement = document.getElementById( args.tagid );
        // Put in a check that adds a class if an ad was actually loaded.
        var adCheckTimer = setInterval(function() {
            if( pecDidAdLoad( adElement ) ){
                adElement.parentNode.classList.add('ad-loaded');
                clearInterval( adCheckTimer);
            }
            if ( checkCount > 200 ) {
                clearInterval( adCheckTimer);
            }
            checkCount++;
        }, 100);
    }
    </script>

	<!-- BEGIN ADVERTSERVE CODE -->
    <script type="text/javascript">
    var _avp = _avp || [];
    (function() {
      var s = document.createElement('script');
      s.type = 'text/javascript'; s.async = true; s.src = 'https://practicalecommerce.advertserve.com/js/libcode3.js';
      var x = document.getElementsByTagName('script')[0];
      x.parentNode.insertBefore(s, x);
    })();
    </script>
    <!-- END ADVERTSERVE CODE -->

    <!-- Start Search Structured Data -->
    <script type="application/ld+json">{
        "@context": "https://schema.org",
        "@type": "WebSite",
        "url": "https://www.practicalecommerce.com",
        "potentialAction": {
            "@type": "SearchAction",
            "target": "https://www.practicalecommerce.com/?s={search_term_string}",
            "query-input": "required name=search_term_string"
        }
    }</script>
    <!-- End Search Structured Data -->
    	<!-- Structured data for posts -->
	<script type="application/ld+json">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</script>
	<!-- End structured data for posts -->
		<!-- Structured data for organization -->
	<script type="application/ld+json">{
    "@context": "http://schema.org",
    "@type": "Organization",
    "name": "Practical Ecommerce",
    "url": "https://www.practicalecommerce.com",
    "logo": "https://www.practicalecommerce.com/wp-content/uploads/2014/04/PEC_hires_no_tag_trans.png",
    "sameAs": [
        "https://www.facebook.com/practicalecommerce",
        "https://www.instagram.com/practical_ecommerce/",
        "https://www.linkedin.com/company/practical-ecommerce/",
        "https://twitter.com/practicalecomm"
    ]
}</script>
	<!-- End structured data for organization -->
	</head>
<body class="post-template-default single single-post postid-367729 single-format-standard unknown" >

    <!-- Google Tag Manager (noscript) -->
    <noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-54R359"
                      height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
    <!-- End Google Tag Manager (noscript) -->


        <div class="container header-container">
            <div class="header row">
                                <div class="full-menu-column">
                    <button class="hamburger hamburger-toggle hamburger--slider" type="button" aria-label="full menu">
	<span class="hamburger-box">
		<span class="hamburger-inner"></span>
	</span>
</button>
<div id="full-menu-container" class="menu-full-menu-container"><ul id="menu-full-menu" class="menu"><li id="menu-item-163957" class="featured-link menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-163957"><a href="https://www.practicalecommerce.com/">Home</a></li>
<li id="menu-item-152818" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152818"><a href="#">Article Categories</a>
<ul class="sub-menu">
	<li id="menu-item-152882" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152882"><a href="https://www.practicalecommerce.com/category/amazon-marketplaces">Amazon &#038; Marketplaces</a></li>
	<li id="menu-item-152883" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152883"><a href="https://www.practicalecommerce.com/category/analytics-data">Analytics &#038; Data</a></li>
	<li id="menu-item-152884" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152884"><a href="https://www.practicalecommerce.com/category/b2b">B2B</a></li>
	<li id="menu-item-152886" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152886"><a href="https://www.practicalecommerce.com/category/conversion">Conversion</a></li>
	<li id="menu-item-152887" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152887"><a href="https://www.practicalecommerce.com/category/design-development">Design &#038; Development</a></li>
	<li id="menu-item-152888" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152888"><a href="https://www.practicalecommerce.com/category/management">Management &#038; Finance</a></li>
	<li id="menu-item-152889" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152889"><a href="https://www.practicalecommerce.com/category/marketing">Marketing &#038; Advertising</a></li>
	<li id="menu-item-190980" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190980"><a href="https://www.practicalecommerce.com/tag/merchant-voice">Merchant Voice</a></li>
	<li id="menu-item-152890" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-152890"><a href="https://www.practicalecommerce.com/category/seo">SEO</a></li>
	<li id="menu-item-152891" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152891"><a href="https://www.practicalecommerce.com/category/shipping-fulfillment">Shipping &#038; Fulfillment</a></li>
</ul>
</li>
<li id="menu-item-152814" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152814"><a href="#">Tools &#038; More</a>
<ul class="sub-menu">
	<li id="menu-item-367374" class="commerceo menu-item menu-item-type-post_type menu-item-object-page menu-item-367374"><a href="https://www.practicalecommerce.com/commerceco"><span class="join">Join</span> Commerce<span class="red">Co</span></a></li>
	<li id="menu-item-186100" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186100"><a href="https://www.practicalecommerce.com/webinars">Webinar U</a></li>
	<li id="menu-item-174409" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174409"><a href="https://www.practicalecommerce.com/tag/podcasts">Podcasts</a></li>
	<li id="menu-item-152817" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152817"><a href="https://www.practicalecommerce.com/vendors">Vendor Directory</a></li>
	<li id="menu-item-361946" class="mid-column-title menu-item menu-item-type-custom menu-item-object-custom menu-item-361946"><a href="#">Guides</a></li>
	<li id="menu-item-361900" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361900"><a href="https://www.practicalecommerce.com/practical-guide-starting-an-ecommerce-business">Starting an Ecommerce Business</a></li>
	<li id="menu-item-361976" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361976"><a href="https://www.practicalecommerce.com/building-an-ecommerce-business-part-19-just-do-it">Building an Ecommerce Business</a></li>
	<li id="menu-item-361973" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361973"><a href="https://www.practicalecommerce.com/credit-card-processing-part-3-reducing-the-cost">Credit Card Processing FAQs</a></li>
	<li id="menu-item-361974" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361974"><a href="https://www.practicalecommerce.com/checklist">Web Marketing Checklist</a></li>
	<li id="menu-item-361972" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361972"><a href="https://www.practicalecommerce.com/SEO-How-to-Part-12-Your-Technical-Toolbox">SEO How-to</a></li>
</ul>
</li>
<li id="menu-item-152806" class="featured-link menu-item menu-item-type-post_type menu-item-object-page menu-item-152806"><a href="https://www.practicalecommerce.com/advertising">Advertising ></a></li>
<li id="menu-item-152804" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152804"><a href="#">About</a>
<ul class="sub-menu">
	<li id="menu-item-152805" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152805"><a href="https://www.practicalecommerce.com/about-us">About Us</a></li>
	<li id="menu-item-152807" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152807"><a href="https://www.practicalecommerce.com/conditions-of-use">Conditions of Use</a></li>
	<li id="menu-item-152809" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152809"><a href="https://www.practicalecommerce.com/contact">Contact Us</a></li>
	<li id="menu-item-152810" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152810"><a href="https://www.practicalecommerce.com/editorial-policy">Editorial Policy</a></li>
	<li id="menu-item-152812" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152812"><a href="https://www.practicalecommerce.com/newsletter-signup">Email Newsletter</a></li>
	<li id="menu-item-152808" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152808"><a href="https://www.practicalecommerce.com/conditions-of-use/media">Logos and Brand Guide</a></li>
	<li id="menu-item-152811" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-152811"><a href="https://www.practicalecommerce.com/privacy-policy">Privacy Policy</a></li>
	<li id="menu-item-152813" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152813"><a href="https://www.practicalecommerce.com/pec-rss">RSS Summary</a></li>
</ul>
</li>
</ul></div>                </div><!-- end .column -->
                <div class="logo-column">
                     <a rel="home" name="Practical Ecommerce Logo" aria-label="Practical Ecommerce Logo" href="https://www.practicalecommerce.com/" title="Insights for modern merchants">
                         <div class="logo"></div>
                    </a>
                </div>
                                    <div class="nav-column">
                        <div class="search-toggle">
                            <i class="fa fa-search"></i>
                        </div>
                        <div class="primary-menu-container desktop-only"><ul id="menu-primary-menu" class="menu"><li id="menu-item-152878" class="categories-menu menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152878"><a href="#">Categories <i class="fa fa-chevron-down"></i></a>
<ul class="sub-menu">
	<li id="menu-item-152868" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152868"><a href="https://www.practicalecommerce.com/category/amazon-marketplaces">Amazon &#038; Marketplaces</a></li>
	<li id="menu-item-152869" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152869"><a href="https://www.practicalecommerce.com/category/analytics-data">Analytics &#038; Data</a></li>
	<li id="menu-item-152870" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152870"><a href="https://www.practicalecommerce.com/category/b2b">B2B</a></li>
	<li id="menu-item-152872" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152872"><a href="https://www.practicalecommerce.com/category/conversion">Conversion</a></li>
	<li id="menu-item-152873" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152873"><a href="https://www.practicalecommerce.com/category/design-development">Design &#038; Development</a></li>
	<li id="menu-item-152874" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152874"><a href="https://www.practicalecommerce.com/category/management">Management &#038; Finance</a></li>
	<li id="menu-item-152875" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152875"><a href="https://www.practicalecommerce.com/category/marketing">Marketing &#038; Advertising</a></li>
	<li id="menu-item-190979" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190979"><a href="https://www.practicalecommerce.com/tag/merchant-voice">Merchant Voice</a></li>
	<li id="menu-item-152876" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-152876"><a href="https://www.practicalecommerce.com/category/seo">SEO</a></li>
	<li id="menu-item-152877" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152877"><a href="https://www.practicalecommerce.com/category/shipping-fulfillment">Shipping &#038; Fulfillment</a></li>
</ul>
</li>
<li id="menu-item-366203" class="commerceco menu-item menu-item-type-post_type menu-item-object-page menu-item-366203"><a href="https://www.practicalecommerce.com/commerceco"><span class="join">Join</span> COMMERCE<span class="red">CO</span></a></li>
<li id="menu-item-186099" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186099"><a href="https://www.practicalecommerce.com/webinars">Webinar U</a></li>
<li id="menu-item-153345" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-153345"><a href="https://www.practicalecommerce.com/vendors">Vendors</a></li>
</ul></div>                        <div id="header-search-container">
                            <form role="search" method="get" id="searchform" action="https://www.practicalecommerce.com"><input type="text" value="" name="s" id="s" placeholder="Keyword or phrase..." /><button type="submit" id="searchsubmit" value="Search" ><i class="fa fa-search"></i></button></form>                            <button class="search-close"><i class="fa fa-close"></i></button>
                        </div>
                    </div>
                    <div class="newsletter-signup">
    <a class="sign-up-button" href="#">Sign Up <i class="fa fa-chevron-down"></i></a>
    <div class="sign-up-popout">
        <h2>Email Newsletter <br />+ Free Ebook</h2>
        <h3>43 Ecommerce Conversion Drivers</h3>
        <div class="signupform">
            <script language="JavaScript" type="text/JavaScript">function isEmail(a){validRegExp=/^([\w-]+(?:[\.\+][\w-]+)*)@((?:[\w-]+\.)*\w[\w-]{0,66})\.([a-z]{2,6}(?:\.[a-z]{2})?)$/i;if(a.search(validRegExp)==-1){alert("Please insert a valid email address");return false}return true}</script>

            <form action="https://practicalecommerce.emailsp.com/frontend/subscribe.aspx" method="post" name="myForm" onsubmit="jQuery.cookie('popup_hide','true',{expires:14,path:'/',domain:'.www.practicalecommerce.com'})">
                <input name="email" aria-label="Email" type="email" placeholder="Enter email address..." required><input name="Submit" type="submit" onClick="return isEmail(document.myForm.email.value)" value="Sign Up" class="newsletter-submit">
                <input type="hidden" name="list" value="3">
                <input name="campo16" value="top-right" type="hidden">
            </form>
        </div>
        <a href="/privacy-policy" class="privacy-policy">Privacy Policy</a>
    </div>
</div>
                            </div>

                            <div class="header row categories-menu-container">
                    <ul id="menu-desktop-categories-menu" class="menu"><li id="menu-item-182287" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182287"><a href="https://www.practicalecommerce.com/category/amazon-marketplaces">Amazon</a></li>
<li id="menu-item-182288" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182288"><a href="https://www.practicalecommerce.com/category/analytics-data">Analytics</a></li>
<li id="menu-item-182289" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182289"><a href="https://www.practicalecommerce.com/category/b2b">B2B</a></li>
<li id="menu-item-182295" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182295"><a href="https://www.practicalecommerce.com/category/conversion">Conversion</a></li>
<li id="menu-item-182290" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182290"><a href="https://www.practicalecommerce.com/category/design-development">Design</a></li>
<li id="menu-item-182291" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182291"><a href="https://www.practicalecommerce.com/category/management">Management</a></li>
<li id="menu-item-182292" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182292"><a href="https://www.practicalecommerce.com/category/marketing">Marketing</a></li>
<li id="menu-item-182293" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-182293"><a href="https://www.practicalecommerce.com/category/seo">SEO</a></li>
<li id="menu-item-182294" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-182294"><a href="https://www.practicalecommerce.com/category/shipping-fulfillment">Shipping</a></li>
</ul>                    <div class="newsletter-signup">
    <a class="sign-up-button" href="#">Sign Up <i class="fa fa-chevron-down"></i></a>
    <div class="sign-up-popout">
        <h2>Email Newsletter <br />+ Free Ebook</h2>
        <h3>43 Ecommerce Conversion Drivers</h3>
        <div class="signupform">
            <script language="JavaScript" type="text/JavaScript">function isEmail(a){validRegExp=/^([\w-]+(?:[\.\+][\w-]+)*)@((?:[\w-]+\.)*\w[\w-]{0,66})\.([a-z]{2,6}(?:\.[a-z]{2})?)$/i;if(a.search(validRegExp)==-1){alert("Please insert a valid email address");return false}return true}</script>

            <form action="https://practicalecommerce.emailsp.com/frontend/subscribe.aspx" method="post" name="myForm" onsubmit="jQuery.cookie('popup_hide','true',{expires:14,path:'/',domain:'.www.practicalecommerce.com'})">
                <input name="email" aria-label="Email" type="email" placeholder="Enter email address..." required><input name="Submit" type="submit" onClick="return isEmail(document.myForm.email.value)" value="Sign Up" class="newsletter-submit">
                <input type="hidden" name="list" value="3">
                <input name="campo16" value="top-right" type="hidden">
            </form>
        </div>
        <a href="/privacy-policy" class="privacy-policy">Privacy Policy</a>
    </div>
</div>
                </div>
                    </div>
        <div class="partners-top row pec-partners-wrapper">    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- BEGIN ADVERTSERVE CODE -->
    <div id="lKEmjrEdjFH3G6i0GKUi" data-responsive="true">
    <script type="text/javascript">
    var _avp = _avp || [];
    _avp.push({ tagid: 'lKEmjrEdjFH3G6i0GKUi', alias: '/', type: 'banner', zid: 2, pid: 0, secure: true, callback: pecAdLoaded });
    </script>
    </div>
    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- END ADVERTSERVE CODE -->

    </div>
	<div class="main row">


	<div class="content ">

					
			<div class="row">
								<a href="https://www.practicalecommerce.com/category/seo" class="cat-link">
                    SEO                </a>
                				<h1 class="entry-header">SEO: Keyword Research for Product Content</h1>
			</div>

			<div class="row content-pad">
				<div class="column col8">

					<div class="entry-meta-con">
						<div class="entry-meta meta-detail">
							<h6>February 14, 2021 &bull; <a rel="author" title="Posts by Armando Roggio" href="https://www.practicalecommerce.com/author/armando-roggio">Armando Roggio</a></h6>

						</div><!-- end meta -->

						<div class="pec-social-post">
							<ul>
								<li><a onclick="ga('send','event','Article Top','Social Twitter');" data-via="practicalecomm @ecommerceboy" data-url="http://pec-ly.com/?1xF7"  target="_blank" data-size="small" data-dir="left" rel="noreferrer" href="https://twitter.com/share?text=SEO: Keyword Research for Product Content&amp;url=http://pec-ly.com/?1xF7&via=practicalecomm" title="Click to share this post on Twitter"><i class="fa fa-twitter"></i></a></li>
								<li><a onclick="ga('send', 'event','Article Top','Social Facebook');" title="Share on Facebook" target="_blank" rel="noreferrer" href="https://www.facebook.com/sharer.php?u=https://www.practicalecommerce.com/seo-keyword-research-for-product-content&t=SEO: Keyword Research for Product Content"><i class="fa fa-facebook"></i></a></li>
								<li><a onclick="ga('send', 'event','Article Top','Email');" href="mailto:?subject=SEO%3A%20Keyword%20Research%20for%20Product%20Content&amp;body=https%3A%2F%2Fwww.practicalecommerce.com%2Fseo-keyword-research-for-product-content" title="Send this article to a friend!"><i class="fa fa-envelope"></i></a></li>
								<li><a title="Print the page" rel="nofollow" href="javascript:void(0)" onclick="ga('send', 'event','Article Top','Print');window.print()"><i class="fa fa-print"></i></a></li>

							</ul>
						</div>

					</div>

					<div class="entry-content">
																		<p>Content on an ecommerce site&#8217;s product detail pages, category pages, and blog can attract visitors and lead to sales and profit.</p>
<p>For many commerce businesses — omnichannel retailers, ecommerce-only merchants, wholesalers — attracting a steady flow of site visitors from organic search results is vital for success. But achieving high rankings in those results requires optimizing a site with relevant content.</p>
<h3>SEO and Content Marketing</h3>
<p>Search engine optimization is the process of organizing a website to communicate its purpose and value to Google, Bing, and similar. The result, hopefully, is highly-ranked pages in search results, producing more and better visitors.</p>
<p><a href="https://www.practicalecommerce.com/tag/content-marketing">Content marketing</a> is the act of creating, publishing, and promoting content to attract, engage, and retain customers. The goal of content marketing and SEO is the same: generate visitors.</p>
<p>For this article, I&#8217;m going to put SEO first in the process.</p>
<p>Content marketers will sometimes create articles or videos that are <em>not</em> directly related to the products their business sells but instead around topics that interest prospects.</p>
<p>For example, an online shop that sells 4&#215;4 truck accessories might produce content about backcountry hiking. Why? Because folks who hike in the backcountry likely drive four-wheel-drive vehicles. The hikers might need a vehicle accessory or two.</p>
<p>Consider the &#8220;Michelin Guide&#8221; series. Michelin, which sells tires, started publishing a series of hotel and restaurant guides about 120 years ago. Folks who stay at hotels and eat at restaurants presumably drive there in an automobile. Eventually those folks will need tires.</p>
<p>Neither of these examples is product-centric. Product content marketing starts with the item to be sold. It is about 4&#215;4 accessories or tires, not about hiking and the best restaurant. Product-centric content marketing requires <em>keyword research</em>.</p>
<h3>Seeds</h3>
<p>As with any form of SEO keyword research, start with <a href="https://www.practicalecommerce.com/how-to-find-seed-keywords-and-explore-topic-clusters">seed words</a>. For an ecommerce business, these keywords might be the names of its product categories.</p>
<p>For example, if it went looking for seed keywords, a pet-supplies store might pick &#8220;dog food,&#8221; &#8220;dog treats,&#8221; &#8220;dog toys,&#8221; &#8220;dog leashes,&#8221; &#8220;dog collars,&#8221; and similar. These are the product category names for Menards, which sells pet goods in addition to home improvement items.</p>
<div id="attachment_367730" style="width: 580px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-367730" class="wp-image-367730 size-large" title="Screenshot of Menard's pet categories web page" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-570x360.jpg" alt="Screenshot of Menard's pet categories web page" width="570" height="360" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-570x360.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-300x190.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-768x485.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-150x95.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff-500x316.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-menards-dog-stuff.jpg 1000w" sizes="(max-width: 570px) 100vw, 570px" /><p id="caption-attachment-367730" class="wp-caption-text">If it were doing product content marketing for pet supplies, Menards might start with category names as keywords.</p></div>
<p>In the same way, an online retailer selling shoes might select seed keywords such as &#8220;sneakers,&#8221; &#8220;loafers,&#8221; &#8220;boots,&#8221; and even &#8220;tuxedo shoes&#8221; for its product content marketing. Those are the <a href="https://www.practicalecommerce.com/scalable-seo-strategies-to-boost-category-pages">category names</a> for Suitsupply.</p>
<div id="attachment_367738" style="width: 580px" class="wp-caption alignnone"><img aria-describedby="caption-attachment-367738" class="wp-image-367738 size-large" title="Screenshot of Suitsupply's category page for shoes." src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-570x319.jpg" alt="Screenshot of Suitsupply's category page for shoes." width="570" height="319" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-570x319.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-300x168.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-768x430.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-150x84.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply-500x280.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-suitsupply.jpg 1000w" sizes="(max-width: 570px) 100vw, 570px" /><p id="caption-attachment-367738" class="wp-caption-text">Suitsupply&#8217;s category names for shoes are potential keywords for optimizing organic search.</p></div>
<h3>Keyword Ideas</h3>
<p>Using the list of seeds, start to generate other keyword ideas. Look for the phrases shoppers use when searching for your products or services. <a href="https://www.practicalecommerce.com/indispensable-seo-tools-free-expensive">Many tools</a> can help. For example, Google&#8217;s auto-suggest feature shows popular and relevant keyword phrases.</p>
<p>If you enter the phrase &#8220;dog toy&#8221; in Google search, auto-suggest shows keyword phrases such as:</p>
<ul>
<li>&#8220;Dog toys for big dogs,&#8221;</li>
<li>&#8220;Dog toys for chewers,&#8221;</li>
<li>&#8220;Dog toys for small dogs,&#8221;</li>
<li>&#8220;Dog toys made in USA,&#8221;</li>
<li>&#8220;Dog toys with toys inside.&#8221;</li>
</ul>
<div id="attachment_367737" style="width: 580px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367737" class="wp-image-367737 size-large" title="Screenshot of Google search's auto-suggest for &quot;dog toys.&quot;" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-570x434.jpg" alt="Screenshot of Google search's auto-suggest for &quot;dog toys.&quot;" width="570" height="434" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-570x434.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-300x228.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-768x584.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-150x114.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys-500x381.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-google-dog-toys.jpg 1000w" sizes="(max-width: 570px) 100vw, 570px" /></a><p id="caption-attachment-367737" class="wp-caption-text">Google&#8217;s auto-suggest can produce useful keywords, such as this example for the search query &#8220;dog toys.&#8221;</p></div>
<p>You can find more keywords when you search for one of the suggested phrases. For example, &#8220;Dog toys for big dogs&#8221; leads you to &#8220;large dog toys aggressive chewers.&#8221;</p>
<p>Ahrefs Keywords Explorer is another good option for generating search-engine keyword ideas. Explorer can accept one or several keyword seeds at a time. It can also find keywords for YouTube.</p>
<div id="attachment_367736" style="width: 710px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367736" class="wp-image-367736" title="Screenshot of Ahrefs Keywords Explorer." src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-570x301.jpg" alt="Screenshot of Ahrefs Keywords Explorer." width="700" height="370" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-570x301.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-300x158.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-768x406.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-150x79.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys-500x264.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021121-ahrefs-dog-toys.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-367736" class="wp-caption-text">Ahrefs Keywords Explorer can accept one or several keyword seeds at a time. It is also helpful for finding keywords for YouTube.</p></div>
<p>Add a term or even several terms to Keywords Explorer. In the ensuing results, look for the &#8220;having same terms&#8221; link in the left menu. That report will be a list of thousands of keyword ideas. And for each of these ideas, you can keep digging deeper.</p>
<div id="attachment_367820" style="width: 710px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367820" class="wp-image-367820" title="Screen of Ahrefs keywords report" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-570x460.jpg" alt="Screen of Ahrefs keywords report" width="700" height="565" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-570x460.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-300x242.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-768x620.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-150x121.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2-500x404.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-toys-have-same-2.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-367820" class="wp-caption-text">The &#8220;having same terms&#8221; reports in Ahrefs is helpful for generating keyword ideas based on your seed phrases.</p></div>
<p>Finally, SEMrush&#8217;s Keyword Magic Tool is also an excellent way to generate keyword ideas based on product-centric seed phrases.</p>
<div id="attachment_367734" style="width: 710px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367734" class="wp-image-367734" title="Screenshot of SEMrush's Keyword Magic Tool" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-570x306.jpg" alt="Screenshot of SEMrush's Keyword Magic Tool" width="700" height="375" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-570x306.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-300x161.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-768x412.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-150x80.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush-500x268.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-keyword-magic-semrush.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-367734" class="wp-caption-text">SEMrush&#8217;s Keyword Magic Tool is an excellent way to generate keyword ideas based on seed phrases.</p></div>
<h3>Sorting Keywords</h3>
<p>The next step in product-specific research is to sort the keywords.</p>
<p>If you used a manual process such as Google&#8217;s auto-suggest, build a spreadsheet and then capture more info about the keyword phrase using Ahrefs, SEMrush, Google Ads <a href="https://www.practicalecommerce.com/SEO-How-to-Part-7-Mapping-Keywords-to-Content">Keywords Planner</a>, or similar. Essential details include:</p>
<ul>
<li>Monthly search volume,</li>
<li>Keyword difficulty,</li>
<li>Parent topic.</li>
</ul>
<p>Consider also:</p>
<ul>
<li>Average PPC cost,</li>
<li>Competitive density,</li>
<li>Your company&#8217;s current rank.</li>
</ul>
<p>Then use Ahrefs, SEMrush, or similar to sort, such as for these keyword phrases:</p>
<ul>
<li>dog food,</li>
<li>dog treats,</li>
<li>dog toys,</li>
<li>dog leashes,</li>
<li>dog collars.</li>
</ul>
<p>We could enter all of these into the Ahrefs Keywords Explorer and look for the ideas under the &#8220;having same terms&#8221; report. There are more than half a million keyword phrase ideas there.</p>
<div id="attachment_367830" style="width: 710px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367830" class="wp-image-367830" title="Screenshot of Ahrefs dog-related keyword report" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3.jpg" alt="Screenshot of Ahrefs dog-related keyword report" width="700" height="370" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3.jpg 1000w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3-300x158.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3-570x301.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3-768x406.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3-150x79.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/Ahrefs-dog-items-report-3-500x264.jpg 500w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-367830" class="wp-caption-text">The Ahrefs report for dog-related product terms generated more than 518,207 keyword ideas.</p></div>
<p>You could sort by the search volume and look for phrases with more than 250 monthly searches. You might also filter for terms that are relatively easier to rank for, those with a maximum keyword difficulty of 20.</p>
<p>Applying both filters in Ahrefs — search volume and keyword difficulty — would narrow the list to 855 phrases.</p>
<div id="attachment_367732" style="width: 710px" class="wp-caption alignnone"><a href="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results.jpg" target="_blank" rel="nofollow noopener noreferrer"><img aria-describedby="caption-attachment-367732" class="wp-image-367732" title="Screenshot in Ahrefs for sorting dog-related keywords by search volume and difficulty" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-570x334.jpg" alt="Screenshot in Ahrefs for sorting dog-related keywords by search volume and difficulty" width="700" height="410" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-570x334.jpg 570w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-300x176.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-768x450.jpg 768w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-150x88.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results-500x293.jpg 500w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/021221-ahrefs-filtered-results.jpg 1000w" sizes="(max-width: 700px) 100vw, 700px" /></a><p id="caption-attachment-367732" class="wp-caption-text">Filtering in Ahrefs dog-related keywords by search volume and difficulty narrows the list to 855 phrases.</p></div>
<h3>Keyword Intent</h3>
<p>Whether one has created a spreadsheet or used the filter feature in a keyword tool, it is now time to categorize by intent. <a href="https://www.practicalecommerce.com/4-Types-of-Keyword-Intent-That-Impact-Search-Marketing">Keyword intent</a> identifies the goal of the searcher.</p>
<p>Not every search phrase is clear. But others signal obvious intent, such as:</p>
<ul>
<li><em>Navigational.</em> Brand names or product names.</li>
<li><em>Informational.</em> These include words such as &#8220;how,&#8221; &#8220;why,&#8221; &#8220;what,&#8221; &#8220;help,&#8221; and &#8220;guide.&#8221;</li>
<li><em>Investigational.</em> Words such as &#8220;best,&#8221; &#8220;top,&#8221; &#8220;review,&#8221; and &#8220;price&#8221; typify this intent.</li>
<li><em>Transactional.</em> Here look for modifiers such as &#8220;buy,&#8221; &#8220;coupon,&#8221; &#8220;deals,&#8221; and similar.</li>
</ul>
<h3>Create Content</h3>
<p>Finally, select the keyword phrases to create content around. Apply a simple question: Given a keyword phrase, can your business create an article that would benefit the reader and easily connect to one of your products?</p>
                    </div>
                    <div class="post-footer">
                        <div class="article-sharing">
                            <input class="shortened-url" name="shortened-url" title="Shortened URL" value="http://pec-ly.com/?1xF7" type="text"></li>
                        </div>
                        <div class="post-navigation">
                                                            <span class="prev-link">
                                    <a href="https://www.practicalecommerce.com/ridge-wallet-hits-50-million-with-influencer-marketing" rel="prev" onclick="ga('send', 'event','Previous/Next','Previous');">
                                        <span class="left-angle">&#9001;</span>
                                        <span class="label">Previous Article</span>
                                    </a>
                                </span>
                                                        </div>
                    </div>

																							<section id="authorinfo">

								<div class="authorinfo-img">
                                    									    <img src="https://www.practicalecommerce.com/wp-content/uploads/userphoto/391.png" alt="Armando Roggio" width="100" height="129" class="photo" align="left" />                                    								</div>

								<div id="authorname">
									<h2>Armando Roggio</h2>
									<a href="/author/armando-roggio">Bio</a>&nbsp;&nbsp; &#8226; &nbsp;&nbsp;<a href="/author/armando-roggio/feed">RSS Feed</a>
								</div>

								<br clear="both" />
                            </section>

                                                            <div class="post-tags">
                                    More: &nbsp; &nbsp; <a href="https://www.practicalecommerce.com/tag/content-marketing" rel="tag">Content Marketing</a>                                </div>
                            
							<div class="related-posts">
<div id="related-posts-MRP_all" class="related-posts-type">
<ul>
<li><a href="https://www.practicalecommerce.com/seo-for-google-shopping"><img width="288" height="216" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-for-Google-Shopping-288x216.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="ScImage of a smartphone with Google Shopping logo on the screen." /></a><a href="https://www.practicalecommerce.com/category/seo" class="cat-link">SEO</a><br /><a href="https://www.practicalecommerce.com/seo-for-google-shopping">SEO for Google Shopping</a></li>
<li><a href="https://www.practicalecommerce.com/seo-common-fixes-to-core-web-vitals"><img width="288" height="216" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Common-Fixes-to-Core-Web-Vitals-288x216.jpg" class="attachment-post-thumbnail size-post-thumbnail wp-post-image" alt="Screenshot of PageSpeed Insights" /></a><a href="https://www.practicalecommerce.com/category/seo" class="cat-link">SEO</a><br /><a href="https://www.practicalecommerce.com/seo-common-fixes-to-core-web-vitals">SEO: Common Fixes to Core Web Vitals</a></li>
</ul></div>
</div>							<br clear="both" />
																				
                
			</div><!-- end col7x -->




						<div class="sidebar column col4">
	        <div class="partners-sidebar pec-partners-wrapper">
                <span class="ad-label" style="display: none">Advertisement</span>
    <!-- BEGIN ADVERTSERVE CODE -->
    <div id="BEDVyCPr2MXUDa84k2Kg" >
    <script type="text/javascript">
    var _avp = _avp || [];
    _avp.push({ tagid: 'BEDVyCPr2MXUDa84k2Kg', alias: '/', type: 'banner', zid: 5, pid: 0, secure: true, callback: pecAdLoaded });
    </script>
    </div>
    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- END ADVERTSERVE CODE -->

            </div>
    	
	
		<section class="sidebar-tabs">
    <div class="sidebar-tab-title">Popular</div>
    <div id="sidebar-tab-popular"><ul><li><a href='https://www.practicalecommerce.com/8-commercial-drone-delivery-companies' onclick="ga('send','event','Popular','8 Commercial Drone Delivery Companies');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/8-Drone-Delivery-Companies-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Screenshot of a DHL drone in flight" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/01/8-Drone-Delivery-Companies-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/8-Drone-Delivery-Companies-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/8-Drone-Delivery-Companies.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />8 Commercial Drone Delivery Companies</a></li><li><a href='https://www.practicalecommerce.com/seo-common-fixes-to-core-web-vitals' onclick="ga('send','event','Popular','SEO: Common Fixes to Core Web Vitals');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Common-Fixes-to-Core-Web-Vitals-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Screenshot of PageSpeed Insights" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Common-Fixes-to-Core-Web-Vitals-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Common-Fixes-to-Core-Web-Vitals-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/SEO-Common-Fixes-to-Core-Web-Vitals.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />SEO: Common Fixes to Core Web Vitals</a></li><li><a href='https://www.practicalecommerce.com/using-tiktok-for-ecommerce-marketing' onclick="ga('send','event','Popular','Using TikTok for Ecommerce Marketing');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/Using-TikTok-for-Ecommerce-Marketing-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Photo of a young male holding a smartphone with TikTok app on it" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/01/Using-TikTok-for-Ecommerce-Marketing-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/Using-TikTok-for-Ecommerce-Marketing-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/Using-TikTok-for-Ecommerce-Marketing.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />Using TikTok for Ecommerce Marketing</a></li><li><a href='https://www.practicalecommerce.com/ecommerce-product-releases-february-1-2021' onclick="ga('send','event','Popular','Ecommerce Product Releases: February 1, 2021');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/Ecommerce-Product-Releases-February-1-2021-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Photo of a Shopify web developer on a skateboard" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/01/Ecommerce-Product-Releases-February-1-2021-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/Ecommerce-Product-Releases-February-1-2021-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/Ecommerce-Product-Releases-February-1-2021.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />Ecommerce Product Releases: February 1, 2021</a></li><li><a href='https://www.practicalecommerce.com/adding-sms-to-an-ecommerce-marketing-mix' onclick="ga('send','event','Popular','Adding SMS to an Ecommerce Marketing Mix');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/012721-featured-sms-user-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Photo of a female on a subway looking at her smartphone" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/01/012721-featured-sms-user-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/012721-featured-sms-user-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/012721-featured-sms-user.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />Adding SMS to an Ecommerce Marketing Mix</a></li><li><a href='https://www.practicalecommerce.com/5-content-marketing-ideas-for-march-2021' onclick="ga('send','event','Popular','5 Content Marketing Ideas for March 2021');"><img width="70" height="47" src="https://www.practicalecommerce.com/wp-content/uploads/2021/02/020221-featured-content-shamrock-300x200.jpg" class="attachment-70x70 size-70x70 wp-post-image" alt="Photo of a clover (a shamrock)" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/02/020221-featured-content-shamrock-300x200.jpg 300w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/020221-featured-content-shamrock-150x100.jpg 150w, https://www.practicalecommerce.com/wp-content/uploads/2021/02/020221-featured-content-shamrock.jpg 360w" sizes="(max-width: 70px) 100vw, 70px" />5 Content Marketing Ideas for March 2021</a></li></ul>&nbsp;</div>
</section>

			<section class="sidebar-tabs" id="sidebar-tab-our-partners">
		<div class="sidebar-tab-title">Our Partners</div>
		<ul>
																<li>
						<a href="https://userreplay.com" rel="nofollow">
							<img width="180" height="48" src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/UR-Logo-Gradient.jpg" class="attachment-180x999 size-180x999 wp-post-image" alt="UserReplay" title="UserReplay" srcset="https://www.practicalecommerce.com/wp-content/uploads/2021/01/UR-Logo-Gradient.jpg 180w, https://www.practicalecommerce.com/wp-content/uploads/2021/01/UR-Logo-Gradient-150x40.jpg 150w" sizes="(max-width: 180px) 100vw, 180px" />						</a>
					</li>
																				<li>
						<a href="https://www.rakutensl.com/?utm_source=google&utm_medium=ad&utm_campaign=PracticaleCommerce_Thriving_RSLLogo" rel="nofollow">
							<img width="180" height="50" src="https://www.practicalecommerce.com/wp-content/uploads/2020/06/Rakutenlogo180x50.jpg" class="attachment-180x999 size-180x999 wp-post-image" alt="Rakuten Super Logistics" title="Rakuten Super Logistics" srcset="https://www.practicalecommerce.com/wp-content/uploads/2020/06/Rakutenlogo180x50.jpg 180w, https://www.practicalecommerce.com/wp-content/uploads/2020/06/Rakutenlogo180x50-150x42.jpg 150w" sizes="(max-width: 180px) 100vw, 180px" />						</a>
					</li>
									</ul>
	</section>

        <div class="newsletter-form">
    <div class="newsletter-cover">
        <img src="https://www.practicalecommerce.com/wp-content/themes/pec/images/book-sidebox-2021.png" alt="52 great ecommerce ideas" />
    </div>

    <div class="newsletter-title">
        <img src="https://www.practicalecommerce.com/wp-content/themes/pec/images/icon-email.png" class="email-icon" alt="email-news" width="43" height="43" />
        <h2>Email Newsletter<br /> + Free Ebook</h2>
        <h3>43 Ecommerce<br /> Conversion Drivers</h3>

     </div>
     <div class="signupform">
             <!-- jquery -->
<script type="text/javascript">
var $J = jQuery.noConflict();
</script>
<!-- datepicker -->
<form method="POST" action="https://practicalecommerce.activehosted.com/proc.php" id="_form_9_" class="_form _form_9 _inline-form  _dark" novalidate>
  <input type="hidden" name="u" value="9" />
  <input type="hidden" name="f" value="9" />
  <input type="hidden" name="s" />
  <input type="hidden" name="c" value="0" />
  <input type="hidden" name="m" value="0" />
  <input type="hidden" name="act" value="sub" />
  <input type="hidden" name="v" value="2" />
  <div class="_form-content">
    <div class="_form_element _x54843973 _full_width " >
        <input type="text" name="email" aria-label="Email" placeholder="Enter email address..." required/><button id="_form_9_submit" class="_submit" type="submit">
            Sign Up
        </button>
    </div>
    <div class="_clear-element">
    </div>
  </div>
  <div class="_form-thank-you" style="display:none;">
  </div>
</form>
<script type="text/javascript">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</script>
         </div>
     <a href="/privacy-policy" class="privacy-policy">Privacy Policy</a>

</div><!-- end .newsletter-form -->

					    <section class="sidebar-tabs" id="sidebar-tab-knowledge-briefs">
        <div class="sidebar-tab-title">Industry IQ</div>
                    
            <div class="iq-item">
                <div class="iq-icon">
                                            <a href="https://info.userreplay.com/gartner_10_things_covid-19_changes_in_digital_commerce_practical_ecommerce" rel="nofollow" onclick="ga( 'send','event','IQ Box','UserReplay');"><img src="https://www.practicalecommerce.com/wp-content/uploads/2021/01/UserReplay-favicon.jpg" alt="UserReplay" title="UserReplay"/></a>
                                    </div><div class="iq-content">
                    <a href="https://info.userreplay.com/gartner_10_things_covid-19_changes_in_digital_commerce_practical_ecommerce" rel="nofollow" onclick="ga( 'send','event','IQ Box','UserReplay');"><h4>Changes in Digital Commerce: Gartner Report<i class="fa fa-external-link" aria-hidden="true"></i></h4></a>
                    <a href="https://info.userreplay.com/gartner_10_things_covid-19_changes_in_digital_commerce_practical_ecommerce" rel="nofollow" onclick="ga( 'send','event','IQ Box','UserReplay');"><h6>UserReplay</h6></a>
                </div>
            </div>
                    
            <div class="iq-item">
                <div class="iq-icon">
                                            <a href="https://www.rakutensl.com/resources/how-to-continue-your-2020-growth-in-the-new-year?utm_source=google&utm_medium=ad&utm_campaign=PracticaleCommerce_Thriving_ebook" rel="nofollow" onclick="ga( 'send','event','IQ Box','Rakuten Super Logistics');"><img src="https://www.practicalecommerce.com/wp-content/uploads/2020/06/Rakuten32.jpg" alt="Rakuten Super Logistics" title="Rakuten Super Logistics"/></a>
                                    </div><div class="iq-content">
                    <a href="https://www.rakutensl.com/resources/how-to-continue-your-2020-growth-in-the-new-year?utm_source=google&utm_medium=ad&utm_campaign=PracticaleCommerce_Thriving_ebook" rel="nofollow" onclick="ga( 'send','event','IQ Box','Rakuten Super Logistics');"><h4>Continue Your 2020 Growth in the New Year<i class="fa fa-external-link" aria-hidden="true"></i></h4></a>
                    <a href="https://www.rakutensl.com/resources/how-to-continue-your-2020-growth-in-the-new-year?utm_source=google&utm_medium=ad&utm_campaign=PracticaleCommerce_Thriving_ebook" rel="nofollow" onclick="ga( 'send','event','IQ Box','Rakuten Super Logistics');"><h6>Rakuten Super Logistics</h6></a>
                </div>
            </div>
        
    </section>
		
        <div class="partners-sidebar partners-overflow-sidebar pec-partners-wrapper">
                <span class="ad-label" style="display: none">Advertisement</span>
    <!-- BEGIN ADVERTSERVE CODE -->
    <div id="zi4y2TEJdhcyxeMF8Qov" data-responsive="true">
    <script type="text/javascript">
    var _avp = _avp || [];
    _avp.push({ tagid: 'zi4y2TEJdhcyxeMF8Qov', alias: '/', type: 'banner', zid: 6, pid: 0, secure: true, callback: pecAdLoaded });
    </script>
    </div>
    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- END ADVERTSERVE CODE -->

            </div>

	</div>
		</div> <!-- end row -->
	</div>


		 </div>
		<div class="partners-bottom row pec-partners-wrapper">    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- BEGIN ADVERTSERVE CODE -->
    <div id="4mLnts8QZJxw6Fg1iXK3" data-responsive="true">
    <script type="text/javascript">
    var _avp = _avp || [];
    _avp.push({ tagid: '4mLnts8QZJxw6Fg1iXK3', alias: '/', type: 'banner', zid: 4, pid: 0, secure: true, callback: pecAdLoaded });
    </script>
    </div>
    <span class="ad-label" style="display: none">Advertisement</span>
    <!-- END ADVERTSERVE CODE -->

    </div>		<div class="footer">
			<div class="row">
				<div class="footer-nav">
					<div class="footer-nav-left"><ul id="menu-footer-left" class="menu"><li id="menu-item-163958" class="featured-link menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-163958"><a href="https://www.practicalecommerce.com/">Home</a></li>
<li id="menu-item-152833" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152833"><a href="#">Article Categories</a>
<ul class="sub-menu">
	<li id="menu-item-152892" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152892"><a href="https://www.practicalecommerce.com/category/amazon-marketplaces">Amazon &#038; Marketplaces</a></li>
	<li id="menu-item-152893" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152893"><a href="https://www.practicalecommerce.com/category/analytics-data">Analytics &#038; Data</a></li>
	<li id="menu-item-152894" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152894"><a href="https://www.practicalecommerce.com/category/b2b">B2B</a></li>
	<li id="menu-item-152896" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152896"><a href="https://www.practicalecommerce.com/category/conversion">Conversion</a></li>
	<li id="menu-item-152897" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152897"><a href="https://www.practicalecommerce.com/category/design-development">Design &#038; Development</a></li>
	<li id="menu-item-152898" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152898"><a href="https://www.practicalecommerce.com/category/management">Management &#038; Finance</a></li>
	<li id="menu-item-152899" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152899"><a href="https://www.practicalecommerce.com/category/marketing">Marketing &#038; Advertising</a></li>
	<li id="menu-item-190978" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-190978"><a href="https://www.practicalecommerce.com/tag/merchant-voice">Merchant Voice</a></li>
	<li id="menu-item-152900" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-152900"><a href="https://www.practicalecommerce.com/category/seo">SEO</a></li>
	<li id="menu-item-152901" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-152901"><a href="https://www.practicalecommerce.com/category/shipping-fulfillment">Shipping &#038; Fulfillment</a></li>
</ul>
</li>
</ul></div>					<div class="footer-nav-center"><ul id="menu-footer-center" class="menu"><li id="menu-item-152829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152829"><a href="#">Tools &#038; More</a>
<ul class="sub-menu">
	<li id="menu-item-366202" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-366202"><a href="https://www.practicalecommerce.com/commerceco">Join CommerceCo</a></li>
	<li id="menu-item-186098" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-186098"><a href="https://www.practicalecommerce.com/webinars">Webinar U</a></li>
	<li id="menu-item-174408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-174408"><a href="https://www.practicalecommerce.com/tag/podcasts">Podcasts</a></li>
	<li id="menu-item-152831" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152831"><a href="https://www.practicalecommerce.com/vendors">Vendor Directory</a></li>
</ul>
</li>
<li id="menu-item-361902" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-361902"><a href="#">Guides</a>
<ul class="sub-menu">
	<li id="menu-item-361903" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361903"><a href="https://www.practicalecommerce.com/practical-guide-starting-an-ecommerce-business">Starting an Ecommerce Business</a></li>
	<li id="menu-item-361975" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361975"><a href="https://www.practicalecommerce.com/building-an-ecommerce-business-part-19-just-do-it">Building an Ecommerce Business</a></li>
	<li id="menu-item-361970" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361970"><a href="https://www.practicalecommerce.com/credit-card-processing-part-3-reducing-the-cost">Credit Card Processing FAQs</a></li>
	<li id="menu-item-361969" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361969"><a href="https://www.practicalecommerce.com/checklist">Web Marketing Checklist</a></li>
	<li id="menu-item-361971" class="menu-item menu-item-type-post_type menu-item-object-post menu-item-361971"><a href="https://www.practicalecommerce.com/SEO-How-to-Part-12-Your-Technical-Toolbox">SEO How-to</a></li>
</ul>
</li>
</ul></div>					<div class="footer-nav-right"><ul id="menu-footer-right" class="menu"><li id="menu-item-152821" class="featured-link menu-item menu-item-type-post_type menu-item-object-page menu-item-152821"><a title="Advertising" href="https://www.practicalecommerce.com/advertising">Advertising ></a></li>
<li id="menu-item-152819" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-152819"><a href="#">About</a>
<ul class="sub-menu">
	<li id="menu-item-152820" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152820"><a href="https://www.practicalecommerce.com/about-us">About Us</a></li>
	<li id="menu-item-152822" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152822"><a href="https://www.practicalecommerce.com/conditions-of-use">Conditions of Use</a></li>
	<li id="menu-item-152824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152824"><a href="https://www.practicalecommerce.com/contact">Contact Us</a></li>
	<li id="menu-item-152825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152825"><a href="https://www.practicalecommerce.com/editorial-policy">Editorial Policy</a></li>
	<li id="menu-item-152828" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152828"><a href="https://www.practicalecommerce.com/newsletter-signup">Email Newsletter</a></li>
	<li id="menu-item-152823" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152823"><a href="https://www.practicalecommerce.com/conditions-of-use/media">Logos and Brand Guide</a></li>
	<li id="menu-item-152827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-privacy-policy menu-item-152827"><a href="https://www.practicalecommerce.com/privacy-policy">Privacy Policy</a></li>
	<li id="menu-item-152826" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-152826"><a href="https://www.practicalecommerce.com/pec-rss">RSS Summary</a></li>
</ul>
</li>
</ul></div>					<div class="footer-disclaimer">
						<div class="textwidget custom-html-widget">Practical Ecommerce is an independent, family-owned, online magazine in Traverse City, Michigan, U.S. We are not affiliated with any e-commerce service, platform, or provider. Our mission is to publish authoritative articles, commentary, webinars, and podcasts to help online merchants.</div>					</div>
				</div>
				<div class="footer-social">
					<div class="menu-social-links-container"><ul id="menu-social-links" class="menu"><li id="menu-item-57411" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57411"><a title="Twitter" href="https://twitter.com/practicalecomm"><i class="fa fa-twitter"></i></a></li>
<li id="menu-item-57412" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57412"><a title="Facebook" href="https://www.facebook.com/practicalecommerce"><i class="fa fa-facebook"></i></a></li>
<li id="menu-item-366563" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-366563"><a href="https://www.instagram.com/practical_ecommerce/"><i class="fa fa-instagram"></i></a></li>
<li id="menu-item-57408" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57408"><a title="RSS" href="/pec-rss"><i class="fa fa-rss"></i></a></li>
<li id="menu-item-57410" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-57410"><a title="LinkedIn" href="http://www.linkedin.com/company/practical-ecommerce"><i class="fa fa-linkedin"></i></a></li>
<li id="menu-item-69187" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-69187"><a title="SoundCloud" href="https://soundcloud.com/practicalecommerce"><i class="fa fa-soundcloud"></i></a></li>
</ul></div>				</div>
				<div class="footer-attribution">
					<img class="logo" src="https://www.practicalecommerce.com/wp-content/uploads/2014/04/PEC_hires_no_tag_trans.png" alt="" />					<p>
						Copyright &#169; 2005 - 2021.<br />
						Practical Ecommerce&#174; is a <br />
						registered trademark of  <br />
						Confluence Distribution, Inc.  <br /></p>
				</div>
			</div>
		</div>
		<style>
#spmask {
  position:absolute;
  left:0;
  top:0;
  z-index:9999;
  background-color:#000;
  display:none;
}
  
#boxes .window {
  position:fixed;  left:0;
  top:0;
  width:auto;
  height:auto;
  display:none;
  z-index:9999;
  padding:20px;
    	border-radius: 5px;
  	-moz-border-radius: 5px;
  	-webkit-border-radius: 5px;
    box-shadow: 0 0 18px rgba(0, 0, 0, 0.4);
}

#boxes #dialog {
  max-width:800px; 
  height:auto;
  _width:0;
  white-space:normal;
  overflow:visible;
  padding:10px;
  border:0px solid #000000;
 
  
}

*html #boxes .window {
    position: absolute;
}

#boxes .window .close {
    right: -19px;
    margin:0px;
    padding:0px;
    position: absolute;
    top: -19px;
    border-radius: 30px;
    background: #333333;
    border: 2px solid #ffffff;
    width: 24px;
    height: 24px;
    color: #ffffff;
    font-family: Arial, sans-serif;
    font-size: 17px;
    font-weight: 400;
    line-height: 22px;
    text-align: center;
}
#boxes .window .close:hover{
    text-decoration: none;
    background: #666666;
}

#sp_credit_link
{
	padding:10px;
	width:auto;
	height: 36px;
	text-align:center;
	margin-bottom: 0px;
	margin-left: 0px;
	margin-right: 0px;
	margin-top: 0px;
	padding-bottom: 0px;
	padding-left: 0px;
	padding-right: 0px;
	padding-top: 0px;
	position: absolute;
	bottom: -40px;
	
 }
@media only screen and (max-width: 768px) {
    #spmask{
        display: none !important;
    }
    #simple-popup{
        display:none !important;
    }
    #boxes #dialog{
        display:none !important;
    }
}

</style>
<div id="spmask"></div>
						</div><a id="simple-popup" name="simplepopup" href="#dialog"></a><div id="boxes"><div id="dialog" class="window"><div class="newsletter-form">
<div class="newsletter-form-content">

<img class="email-icon" src="/wp-content/themes/pec/images/icon-email2.png" alt="email-news-env" width="48" height="36" />
<div class="newsletter-title">
<h2>Email Newsletter + Free Ebook</h2>
<h3>43 Ecommerce Conversion Drivers</h3>
</div>
<div class="signupform"><form action="https://practicalecommerce.emailsp.com/frontend/subscribe.aspx" method="post" name="myForm"><input id="newsletter-input" class="popup-input" style="width: 220px;" name="email" required="" type="email" placeholder="Your email address..." /><input name="list" type="hidden" value="3" /><input name="campo16" type="hidden" value="popup" /><input id="newsletter-submit" name="Submit" type="Submit" value="Sign Up" /></form></div>
<a class="privacy-policy" href="/privacy-policy">Privacy Policy</a>

</div>
<div class="newsletter-cover"><img src="/wp-content/themes/pec/images/book-popup-2021.png" alt="" /></div>
</div><a class="close" href="#">x</a></div></div><!--googleoff: all--><div class="wt-cli-cookie-bar-container"><div id="cookie-law-info-bar" data-cli-geo-loc="0" style="padding:10px; box-sizing:border-box; float:left; border:solid 0px #fff; font-size:14px;" class="wt-cli-cookie-bar"><div class="cli-wrapper"><span>We use cookies to tailor your experience and measure site performance. By using this site, you agree to accept our cookies. <a href='https://www.practicalecommerce.com/privacy-policy' id="CONSTANT_OPEN_URL" style="display:inline-block; text-align:center; font-size:14px; padding:8px 16px; border:0px solid rgb(255, 255, 255); line-height:18px;" target="_blank"  class="wt-cli-element medium cli-plugin-button wt-cli-element cli-plugin-main-link" >Privacy Policy</a>. <a role='button' tabindex='0' style="margin:5px; padding:5px 10px; border-color:rgb(255, 255, 255); border-radius:5px; font-size:16px; font-style:normal;" data-cli_action="accept" id="cookie_action_close_header"  class="wt-cli-element medium cli-plugin-button cli-plugin-main-button cookie_action_close_header cli_action_button" >Accept</a> </span></div></div><div id="cookie-law-info-again" style="display:none;"><span id="cookie_hdr_showagain">Privacy & Cookies Policy</span></div><div class="cli-modal" id="cliSettingsPopup" tabindex="-1" role="dialog" aria-labelledby="cliSettingsPopup" aria-hidden="true">
  <div class="cli-modal-dialog" role="document">
    <div class="cli-modal-content cli-bar-popup">
      <button type="button" class="cli-modal-close" id="cliModalClose">
      <svg class="" viewBox="0 0 24 24"><path d="M19 6.41l-1.41-1.41-5.59 5.59-5.59-5.59-1.41 1.41 5.59 5.59-5.59 5.59 1.41 1.41 5.59-5.59 5.59 5.59 1.41-1.41-5.59-5.59z"></path><path d="M0 0h24v24h-24z" fill="none"></path></svg>
      <span class="wt-cli-sr-only">Close</span>
      </button>
      <div class="cli-modal-body">
        <div class="wt-cli-element cli-container-fluid cli-tab-container">
    <div class="cli-row">
        <div class="cli-col-12 cli-align-items-stretch cli-px-0">
            <div class="cli-privacy-overview">
                <h4>Privacy Overview</h4>                   
                <div class="cli-privacy-content">
                    <div class="cli-privacy-content-text">This website uses cookies to improve your experience while you navigate through the website. Out of these cookies, the cookies that are categorized as necessary are stored on your browser as they are essential for the working of basic functionalities of the website. We also use third-party cookies that help us analyze and understand how you use this website. These cookies will be stored in your browser only with your consent. You also have the option to opt-out of these cookies. But opting out of some of these cookies may have an effect on your browsing experience.</div>
                </div>
                <a class="cli-privacy-readmore" data-readmore-text="Show more" data-readless-text="Show less"></a>            </div>
        </div>  
        <div class="cli-col-12 cli-align-items-stretch cli-px-0 cli-tab-section-container">

                
                            <div class="cli-tab-section">
                <div class="cli-tab-header">
                    <a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="necessary" data-toggle="cli-toggle-tab" >
                        Necessary 
                    </a>
                                  
                    <div class="wt-cli-necessary-checkbox">
                        <input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-necessary" data-id="checkbox-necessary" checked="checked"  />
                        <label class="form-check-label" for="wt-cli-checkbox-necessary"> Necessary </label>
                    </div>
                    <span class="cli-necessary-caption">
                        Always Enabled                    </span>                           
                                </div>
                <div class="cli-tab-content">
                    <div class="cli-tab-pane cli-fade" data-id="necessary">
                        <p>Necessary cookies are absolutely essential for the website to function properly. This category only includes cookies that ensures basic functionalities and security features of the website. These cookies do not store any personal information.</p>
                    </div>
                </div>
                </div>
                            <div class="cli-tab-section">
                <div class="cli-tab-header">
                    <a role="button" tabindex="0" class="cli-nav-link cli-settings-mobile" data-target="non-necessary" data-toggle="cli-toggle-tab" >
                        Non Necessary 
                    </a>
                                                <div class="cli-switch">
                    <input type="checkbox" class="cli-user-preference-checkbox"  id="wt-cli-checkbox-non-necessary" data-id="checkbox-non-necessary"   />
                    <label for="wt-cli-checkbox-non-necessary" class="cli-slider" data-cli-enable="Enabled" data-cli-disable="Disabled"><span class="wt-cli-sr-only">non-necessary</span></label>
                </div>    
                                </div>
                <div class="cli-tab-content">
                    <div class="cli-tab-pane cli-fade" data-id="non-necessary">
                        <p>Any cookies that may not be particularly necessary for the website to function and is used specifically to collect user personal data via analytics, ads, other embedded contents are termed as non-necessary cookies. It is mandatory to procure user consent prior to running these cookies on your website.</p>
                    </div>
                </div>
                </div>
                       
        </div>
        <div class="cli-col-12 cli-align-items-stretch cli-px-0">
            <div class="cli-tab-footer">
                                    <a role="button" tabindex="0" class="cli_setting_save_button cli-btn">Save & Accept</a>
                            </div>
        </div>
    </div> 
</div> 
      </div>
    </div>
  </div>
</div>
<div class="cli-modal-backdrop cli-fade cli-settings-overlay"></div>
<div class="cli-modal-backdrop cli-fade cli-popupbar-overlay"></div>
</div>
<script type="text/javascript">
  /* <![CDATA[ */
    cli_cookiebar_settings='{"animate_speed_hide":"500","animate_speed_show":"500","background":"rgb(255, 255, 255)","border":"#b1a6a6c2","border_on":false,"button_1_button_colour":"rgb(26, 68, 128)","button_1_button_hover":"rgb(26, 68, 128)","button_1_link_colour":"rgb(255, 255, 255)","button_1_as_button":true,"button_1_new_win":false,"button_2_button_colour":"rgb(255, 255, 255)","button_2_button_hover":"rgb(255, 255, 255)","button_2_link_colour":"rgb(68, 68, 68)","button_2_as_button":true,"button_2_hidebar":false,"button_2_nofollow":false,"button_3_button_colour":"rgb(0, 0, 0)","button_3_button_hover":"rgb(0, 0, 0)","button_3_link_colour":"#fff","button_3_as_button":true,"button_3_new_win":false,"button_4_button_colour":"rgb(0, 0, 0)","button_4_button_hover":"rgb(0, 0, 0)","button_4_link_colour":"#fff","button_4_as_button":true,"font_family":"inherit","header_fix":false,"notify_animate_hide":true,"notify_animate_show":false,"notify_div_id":"#cookie-law-info-bar","notify_position_horizontal":"right","notify_position_vertical":"bottom","scroll_close":false,"scroll_close_reload":false,"accept_close_reload":false,"reject_close_reload":false,"showagain_tab":false,"showagain_background":"#fff","showagain_border":"#000","showagain_div_id":"#cookie-law-info-again","showagain_x_position":"100px","text":"#000","show_once_yn":false,"show_once":"10000","logging_on":false,"as_popup":false,"popup_overlay":true,"bar_heading_text":"","cookie_bar_as":"banner","cookie_setting_popup":true,"accept_all":true,"js_script_blocker":false,"popup_showagain_position":"bottom-right","widget_position":"left","button_1_style":{"0":["margin","5px"],"1":["padding","5px 10px"],"4":["border-color","rgb(255, 255, 255)"],"5":["border-radius","5px"],"6":["font-size","16px"],"7":["font-style","normal"]},"button_2_style":[["display","inline-block"],["text-align","center"],["font-size","14px"],["padding","8px 16px"],["border","0px solid rgb(255, 255, 255)"],["line-height","18px"]],"button_3_style":[["display","inline-block"],["padding","8px 16px 8px"],["border-radius","4px"],["text-align","center"],["font-size","12px"],["border","solid 0px #fff"],["line-height","18px"]],"button_4_style":[["display","inline-block"],["padding","8px 16px 8px"],["border-radius","4px"],["text-align","center"],["font-size","12px"],["border","solid 0px #fff"],["line-height","18px"]],"button_5_style":{"0":["float","right"],"1":["text-decoration","none"],"2":["color","#333"],"4":["background-color","rgba(0, 0, 0, 0)"]}}';
  /* ]]> */
</script>
<!--googleon: all--><script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/0837cb9f-5537-4a80-a78c-3bb43a326e24.js' defer filler=''></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/0a362f96-d538-4df1-8ee1-38e3e01d86bd.js' defer filler=''></script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/17f2538a-2f68-4906-b7aa-bc89e2ae2918.js' defer filler=''></script>
<script type='text/javascript'>
/* <![CDATA[ */
var aepc_pixel_events = {"custom_events":{"AdvancedEvents":[{"params":{"login_status":"not_logged_in","post_type":"post","object_id":367729,"object_type":"single","tax_category":["SEO"],"tax_post_tag":["Content Marketing"],"tax_yst_prominent_words":["ahrefs keywords explorer","category names","content marketing","dog","dog toys","dog toys for big dogs","generate keyword ideas","keyword","keyword ideas","keyword magic tool","keyword phrases","keyword seeds at a time","keywords","keywords explorer","list to 855 phrases","product content marketing","search volume","semrush's keyword magic","semrush's keyword magic tool","toys for big dogs"]},"delay":0}]}};
/* ]]> */
</script>
<script type='text/javascript' src='https://hb.wpmucdn.com/www.practicalecommerce.com/8d80faac-baba-40f7-a982-a2b21dcd0dbe.js' defer filler=''></script>
<style type="text/css">.wpbdp-listing-excerpt.wpbdp-listing-plan-id-3{background-color: #ecf4fa;}
</style>	</body>
</html>
